Outage - TOPdesk and other Services

Incident Report for University for the Creative Arts

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 10:17 GMT

Update

Posted Dec 05, 2025 - 09:16 GMT

Monitoring

Service has been restored. We will continue to monitor.
Posted Dec 05, 2025 - 09:14 GMT

Update

We are continuing to investigate this issue.
Posted Dec 05, 2025 - 09:12 GMT

Update

The UCA Store is also unavailable due to this ongoing issue.
https://store.ucreative.ac.uk/
Posted Dec 05, 2025 - 09:11 GMT

Investigating

We are aware TOPdesk is currently unavailable.
This appears to be a Cloudflare issue, affecting lots of external services.
Posted Dec 05, 2025 - 09:06 GMT
This incident affected: Corporate Business Systems (The HUB) and Digital Services (UCA Store).