UCA Web Timetables
Incident Report for University for the Creative Arts
Resolved
This incident has been resolved.
Posted Feb 07, 2024 - 08:44 GMT
Investigating
We are currently investigating an issue affecting updates to the UCA web timetables. Our engineers are working with suppliers to resolve this as quickly as possible. Further updates will be posted as they become available.
Posted Feb 06, 2024 - 12:30 GMT
This incident affected: Corporate Business Systems (Timetabling Management System).