Windows Users - Known Teams Issue
Incident Report for University for the Creative Arts
Resolved
We write to update you that this issue has now been resolved. Please log out and log back into Teams if you are still experiencing the issue. Thank you for your cooperation.
Posted Oct 13, 2023 - 15:54 BST
Update
Microsoft Teams is currently affecting many Windows users. While we wait for Microsoft to resolve this issue, we have simple workaround for UCA staff - all files can be opened in the web based application. https://teams.microsoft.com.
Posted Oct 06, 2023 - 11:51 BST
Investigating
We are aware of an issue in Microsoft Teams which is affecting file and document access for Windows users running Teams on version 1.6.00.26474

We anticipate this issue with be fixed by Microsoft soon and will share potential workarounds shortly.
Posted Oct 04, 2023 - 16:56 BST
This incident affected: Office 365 (Microsoft Teams).