Payment Issue Accommodation System

Incident Report for University for the Creative Arts

Resolved

This incident has been resolved.
Posted Jun 24, 2025 - 10:40 BST

Monitoring

Payments are working again. We are continuing to monitor this service.
Posted Jun 23, 2025 - 12:13 BST

Investigating

We are aware of further payment issues over the weekend. These are being investigated with our third party provider.
Posted Jun 23, 2025 - 10:38 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 19, 2025 - 13:56 BST

Identified

A fix has been implemented and we are currently monitoring to see if the changes have fully resolved the issue.
Posted Jun 19, 2025 - 10:18 BST

Update

Unfortunately we haven't found the root cause for this issue, but our engineers are continuing to work with our third party to resolve the issue.
Posted Jun 18, 2025 - 16:35 BST

Update

Our preliminary checks have shown payments are available and working for some students. We are continuing to investigate why this is not working for everyone.
Posted Jun 18, 2025 - 12:19 BST

Update

Our engineers are continuing to investigate this issue with our external provider.
Posted Jun 18, 2025 - 10:31 BST

Investigating

We are aware of an issue affecting the accommodation system where there is no payment option available. This is being investigated as a priority. Further updates will be posted once available.
Posted Jun 18, 2025 - 09:43 BST
This incident affected: Corporate Business Systems (Accommodation System).