iTrent speed issue
Incident Report for University for the Creative Arts
Resolved
This incident has been resolved.
Posted Jan 15, 2024 - 15:55 GMT
Investigating
We are aware that there is currently an issue with the speed of iTrent. The vendor is currently investigating the issue. Thank you for your co-operation.
Posted Jan 15, 2024 - 12:00 GMT