People & Culture: Self-Service and People & Culture: People Manager Services
Incident Report for University for the Creative Arts
Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 14:13 GMT
Investigating
We are aware that some users of People & Culture: People Managers may be seeing a blank screen when they first log in today whilst using Chrome. To resolve this please clear your cache, which can be found under Settings / Privacy and security / Clear browsing data. Thank you for your cooperation.
Posted Feb 28, 2024 - 11:53 GMT
This incident affected: Corporate Business Systems (myHR / Payroll System).