SITS is Unavailable

Incident Report for University for the Creative Arts

Resolved

SITS Update 'A fix has been implemented which we believe has resolved all issues with SITS. We will continue to monitor the service' Once again we would like to thank you for you support.
Posted Sep 18, 2023 - 10:29 BST

Update

We are continuing to work on resolving this ongoing issue as a priority. We will provide another update at 11AM
Posted Sep 18, 2023 - 09:42 BST

Investigating

IDS would like to inform you that SITS is Offline. We hope to resolve this as quickly as possible. Thank you for your support and patience.
Posted Sep 18, 2023 - 09:03 BST
This incident affected: Corporate Business Systems (Students Records System).