Microsoft Office 365 - Distruption
Incident Report for University for the Creative Arts
Resolved
Microsoft are reporting normal service.
Posted Jan 25, 2023 - 12:48 GMT
Investigating
Microsoft are reporting issues with access to some of their Office 365 platform, including Outlook, Teams and OneDrive.

For the latest updates please refer to Microsoft's status page - https://status.office365.com/
Posted Jan 25, 2023 - 08:21 GMT
This incident affected: Office 365 (Outlook (Exchange Online), Office 365 Portal, Microsoft Teams, OneDrive for Business).